[Level 3] Solaris 10 Technical Conference ( 2009/10/25,11/13,12/4 ) -- Advanced SMF hands-on lab
The following is my lab file, please refer to it.
Wish this helps.
regards,
Stanley Huang
Wish this helps.
regards,
Stanley Huang
****************************************************************************************************
The purpose of this lab is to let you have advanced SMF administration skill. And then you will have the following capabilities.
Ref:
1. smfmanifest_howto.pdf
2. http://www.sun.com/software/solaris/howtoguides/servicemgmthowto.jsp
Lab 1:
* create new SMF service.
Lab 1:
1. copy smfSample.xml to /temp/.
# mkdir /temp;
# cp ./smfSample.xml /temp/myService.xml;
2. modify xml file.
# cd /temp;
# vi /temp/myService.xml;
[ find all "REPLACE_ME" to replace ]
3. create myService method.
# vi /temp/myService;
[ service method just like init method, ex. /etc/init.d/apache ]
4. create myService.main.
# vi /temp/myService.main;
[ the service main program ]
5. import service configuration.
# svccfg import /temp/myService.xml;
6. check service status.
# svcs myService;
# svcs -vx myService;
7. enable/disable/restart service.
# svcadm enable myService;
# svcadm disable myService;
# svcadm restart myService;
1. smfmanifest_howto.pdf
2. http://www.sun.com/software/solaris/howtoguides/servicemgmthowto.jsp
Lab 1:
* create new SMF service.
Lab 1:
1. copy smfSample.xml to /temp/.
# mkdir /temp;
# cp ./smfSample.xml /temp/myService.xml;
2. modify xml file.
# cd /temp;
# vi /temp/myService.xml;
[ find all "REPLACE_ME" to replace ]
3. create myService method.
# vi /temp/myService;
[ service method just like init method, ex. /etc/init.d/apache ]
4. create myService.main.
# vi /temp/myService.main;
[ the service main program ]
5. import service configuration.
# svccfg import /temp/myService.xml;
6. check service status.
# svcs myService;
# svcs -vx myService;
7. enable/disable/restart service.
# svcadm enable myService;
# svcadm disable myService;
# svcadm restart myService;
Comments
Post a Comment